Как полностью избавиться от Категории в моем блоге?

Я предпочитаю использовать теги и не заинтересован в использовании категорий. Все мои сообщения теперь обозначены категорией «Без рубрики», и я хочу отключить их! Я не хочу больше категорий. Как я могу это сделать? Пожалуйста помоги!

[Редактировать]

Я использую wordpress.com , а не wordpress.org

Невозможно вообще удалить категорию без рубрики с веб-сайта wordpress.com. Это даже не возможно с самостоящим WordPress без обширного взлома темы и ядра.

Категория без рубрики – это местозаполнитель для должности, не имеющей какой-либо категории. Вы даже не можете удалить эту категорию, чтобы не было никаких категорий.

Извините, но ответ отрицательный, нет способа удалить категории . Не на wordpress.com и только с большим изменением общего дизайна wordpress на собственную копию.

Вы вообще не можете отключать категории, но вы можете помешать WP отображать их:

  • на экране редактора сообщений в интерфейсе администратора используйте параметры экрана, чтобы скрыть элемент выбора категорий.

  • в своей теме удалите связанные с категорией строки.

Это не приведет к техническому отключению всех категорий, связанных с показом (WP может по-прежнему выводить, скажем, RSS-каналы категории и т. П. В метатеку HTML, и они все равно будут работать), но большинство ваших авторов и конечных пользователей не будут заметьте их.

Денис прав, нет способа фактически удалить категории в качестве таксономии из пост-типа post. Если вы единственный пользователь, просто используйте параметры экрана, чтобы удалить мета-окно категорий. Если вы хотите удалить его для всех пользователей или пытаетесь упаковать тему без категорий, используйте эту функцию:

 add_action( 'add_meta_boxes', 'hide_categories_metabox' ); function hide_categories_metabox() { remove_meta_box('categorydiv','post','side'); } 

Если вам действительно необходимо полностью удалить функциональность категорий, скройте тип post и отправьте свой собственный текст без поддержки категорий. Просто имейте в виду, что вы не сможете использовать функциональные возможности встроенного архива WP, по крайней мере до 3.1 …?