Intereting Posts
Загружайте медиафайлы на S3 без использования WP Uploader Изменение элемента в раскрывающемся списке после 5 последних сообщений в таксономии Как я могу исключить код из страниц вложения изображений? Согласование типов содержимого базы данных с типами PHP Автоматическое создание многосайтового блога при регистрации пользователя Где вызывать wp_enqueue_script в плагине с настраиваемым шаблоном? Архив пользовательских сообщений в виде страницы Пользовательские сообщения на разных страницах Как дублировать одну запись со всеми ее свойствами и сохранять ее как другую запись? Как показать вид больше на моем ярлыке страниц Как форматировать настраиваемые поля при редактировании вложения? Добавление списка индексов в документе WordPress Полнофункциональный плагин форума Отправить RSS-адрес для Pingomatic с помощью curl и cron? ACF доступа к полю из запроса, но не в сообщении

Как проверить совместимость версии PHP на веб-сайте WordPress?

Мой хост обновляет версию php с 5.4 до 5.6. Я не вижу https: // страницы или login wp-admin с тестовыми сайтами, чтобы видеть проблемы. Я где-то читал, что WordPress рекомендует php 5.6. НО, я не знаю, есть ли у плагинов какие-либо проблемы. Тем не менее, я могу видеть, что ошибок в журнале ошибок нет. Разве ошибка проверки php не означает, что все совместимо?

Solutions Collecting From Web of "Как проверить совместимость версии PHP на веб-сайте WordPress?"

По умолчанию WP очень неохотно показывает или показывает какие-либо ошибки. Это связано с его стратегией «ошарашения» вещей.

Конфигурация, которую я использую для контроля за ошибками, находится в строках этого в wp-config.php :

 define( 'WP_DEBUG', true ); define( 'WP_DEBUG_DISPLAY', false ); @ini_set( 'display_errors','Off' ); @ini_set( 'log_errors','On' ); @ini_set( 'error_log','/home/user/logs/php_site_name.log' ); 

Существует также WP native WP_DEBUG_LOG константа, но, к сожалению, они решили сделать ее жестко закодированной для записи журнала в каталог общего контента, что является плохой практикой.

И да, общее обновление до более новой версии PHP обычно приводит к поломке и ошибкам, если что-то несовместимо. Больше нечего делать, кроме обзора кода всего.