Объяснение совместимости плагина WordPress, когда WordPress выпускает свою новую версию (теоретическую)

Недавно я обновил свой wordpress до своей последней version 3.4.1 и заметил, что некоторые из моих плагинов совместимы только с 3.3, хотя они работают правильно для моего сайта даже с последней версией.

Это значит, что мне нужно отключить эти плагины и искать альтернативы, и эти плагины больше не используются SAFE или это что-то еще (я загрузил все плагины только с wordpress.org ).

Нужно лучше разъяснить это, и дайте мне знать, если какая-то концепция им отсутствует с повышением градации :). Подробный ответ действительно оценен, и я сделаю свою часть тогда 🙂