Intereting Posts
Никакой результат не обновляет пользовательское поле, используя wp_schedule_event WP CRON на общедоступном хостинге, который не позволяет соединения с обратной связью? Страница таксономии приводит к 404 страницам в разбивке на страницы Поиск в WordPress с помощью подстановочного знака и вывод найденного текста из всех сообщений, содержащих его WP_Query возвращает изображения, но post_per_page неверен Обновление WP CLI в основных и подпапках Замена _custom_background_cb Захват the_content из «о нас» Как обрабатывать формы из боковых виджетах – Обработка переменных $ _POST с использованием get_field_name () получать изображения из сообщения и делать zip Перевести wordpress date с итальянского на английский Удалите ненужный текст со всех сообщений, используя команду sql Ссылки галереи изображений на средний образ вместо полноразмерного изображения Шаблон одной страницы для пользовательского post_type API Paypal и WordPress

Как перенести супер старую версию (2.0) моего блога на 3.1?

Я не могу использовать какой-либо из подключаемых модулей импорта из-за более старой версии – так что это боль, плюс URL-ссылки всегда являются оптимальными. Есть идеи, как это сделать? Боюсь, мне придется делать это вручную!

import plugin Я имею в виду. изменился формат файла XML-импорта, поэтому я могу использовать его для загрузки контента = / –

Если сайт находится в прямом эфире, вы не должны его напрямую обновлять, хотя обновление в последней версии WordPress очень простое и бесшумное, но в 2.1 это было не так.

Также приведен список шагов, которые я вам рекомендую:

  1. Составьте список всех плагинов.
  2. Убедитесь, что ни один из плагинов не отвечает за основные функции сайта. (Как сказал кайзер, все в порядке, если они только презентационные).
  3. Существует 99% вероятность того, что ваша тема сломается или, по крайней мере, будет жаловаться на устаревшие функции с wordpress 3.1, поэтому у вас есть два варианта: переключитесь на стандартную тему или проверьте свой сайт на наличие ошибок из темы после каждого обновления до тех пор, пока вы не достигнете 3.1
  4. Установите WordPress 2.1 на тестовую машину и клонируйте свой сайт, а не все данные, но, по крайней мере, функциональность.
  5. Отключите все плагины, ответственные за основные функции, которые вы отметили на шаге 2
  6. Перейдите к следующей стабильной версии WordPress, которая была выпущена после вашей текущей версии.
  7. Включите плагины один за другим и проверьте свой тестовый сайт.
  8. Если есть ошибки, посмотрите, можете ли вы исправить их или отключить плагин. Вы также можете увидеть ошибки из своей темы, если вы не переключились на стандартную тему, поэтому попробуйте исправить их.
  9. Если вы обновились до WordPress 3.1, то «Поздравления» еще не достигнуто. Шаг 5.

Надеюсь, это будет полезно для вас, и вам будет легко перейти на 3.1.

Я мог бы что-то упустить, потому что не знаю, почему вы говорите об использовании функций импорта, но вы можете загрузить несколько более старых версий из архива выпуска и обновить постепенно. Попробуйте перейти к 2.5, затем 2.9, затем 3.1.

Если есть какая-то причина, по которой вас беспокоит, что это не сработает, не могли бы вы предоставить более подробную информацию о ситуации?