Intereting Posts
Как получить категорию сообщения и связать ее с архивом (категории) Как загрузить изображения на странице администратора? Как отсортировать категории по id в wordpress admin Как я могу добавить вкладку «Вставить из URL» в пользовательский загрузчик 3,5-медиа? множественный запрос типа запроса с их настраиваемым полем разрешить только регистрацию нижнего регистра Как разбить цикл на два столбца Добавить разбивку на страницы в мой пользовательский цикл изменить функцию короткого кода плагина Как поддержать, позволяя пользователям добавлять свой собственный логотип в пользовательскую тему? Регистр переднего регистра с настраиваемыми полями Массовая замена содержимого нескольких страниц / сообщений? Добавление параметра в цикл продуктов woocommerce Восстановление WP Login Credintials в коде? Объединить пользовательские плагины в одну папку

Невозможно загрузить выбранное изображение в пользовательский тип сообщения.

По какой-то причине я не могу загружать изображения или устанавливать Featured Image в пользовательском типе сообщений в моей пользовательской теме WordPress.

Я добавил тему поддержки эскизов к моему файлу functions.php, и мой пользовательский тип сообщения поддерживает его. Ссылка для добавления улучшенного изображения работает, и это позволяет мне начать загрузку файла. Но перед тем, как файл завершится, он выдаст сообщение об ошибке «Ошибка при загрузке. Повторите попытку позже». Если я непосредственно посещу медиа-библиотеку, файл находится там, но на странице пользовательских сообщений отображается ошибка.

Кроме того, когда я открываю медиа-библиотеку с пользовательской страницы сообщения, она отображается как пустая.

У кого-нибудь есть какие-то мысли о том, почему это так?

Solutions Collecting From Web of "Невозможно загрузить выбранное изображение в пользовательский тип сообщения."

Обязательно define( 'WP_DEBUG', FALSE ); в wp-config.php. По какой-то причине он не позволяет добавлять избранные изображения из настраиваемого типа сообщений с включенной отладкой.

Я нашел ответ. Я использовал функцию, чтобы неправильно установить размеры эскизов. После того, как я изменил эту функцию на правильный формат, она снова начала работать снова.