Javascript не работает в admin

Кажется, что ни один из javascript не работает при входе в раздел администратора моего сайта. Я не могу делать ничего, что требует javascript или AJAX: миниатюры Nextgen, организация Widget, даже меню администратора не работают.

Javascript в интерфейсе сайта работает так, как должен.

Я посмотрел в firebug для скриптов и нашел это (очевидно, загруженный в нижнем колонтитуле):

<script src="http://kainielsen.web44.net/wp-admin/load-scripts.php?c=1&load=jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,hoverIntent,common,jquery-color,wp-ajax-response,wp-lists,jquery-ui-resizable,quicktags,jquery-query,admin-comments,postbox,dashboard,thickbox,plugin-install,media-upload&ver=e0f647a6df61adcc7200ce17a647db7f" type="text/javascript"> 

В некотором роде WordPress, похоже, пытается загрузить все сценарии сразу. Может ли это быть причиной неисправности?

Это обычное поведение WordPress? Или это могло произойти, потому что я использовал W 3 Total Cache?

Конечный вопрос заключается в том, что, если загрузить все сразу, это причина, как его отменить?

Solutions Collecting From Web of "Javascript не работает в admin"

Конкатенация сценариев в области администрирования – это обычное поведение, но я не уверен, что попытка загрузить много скриптов.

Вы можете отключить конкатенацию, CONCATENATE_SCRIPTS константу CONCATENATE_SCRIPTS значение false . В wp-config.php будет подходящим:

 define('CONCATENATE_SCRIPTS', false); 

См. Disable_Javascript_Concatenation в Codex .

W3TC не должен влиять на что-либо на стороне администратора.

Скорее всего, у вас неправильный плагин. Попробуйте отключить все плагины, а затем посмотрите, не исчезла ли проблема. Если да, тогда начинайте сужаться, какой плагин вызывает помехи. Если проблема не исчезнет, ​​отключив все отключенные плагины, попробуйте переключить тему на значение по умолчанию, чтобы убедиться, что это проблема.

У меня была такая же проблема после перехода с моего локального хоста на веб-сервер.

Я заметил, что существуют различия между load-scripts.php, который генерируется локальным хостом и тем, что генерируется веб-сервером. Веб-сервер генерировал «двойные кавычки» в некоторых частях кода кода!

РЕШЕНИЕ (в моем случае): я сравнивал оба php.ini и заметил, что на моем веб-сервере были включены опции «magic_quotes». Отключите их (как на php.ini на localhost) и проблема решена!

Загрузите новую папку wp-admin. Это сработало для меня. Это происходит на некоторых серверах из-за проблем, возникающих при загрузке файлов.