Настройка jQuery noConflict для использования только для плагина?

Я немного потерял, я пытаюсь сделать плагин только для использования этой конкретной версии jQuery, чтобы он не противоречил другим версиям, которые находятся на сайте.

Это то, что я пробовал, и я думал, что это сработало бы, но я думаю, это не так.

wp_register_script('jquery-1.4.4', plugin_dir_url( __FILE__ ) . 'js/reveal/jquery-1.4.4.js', false, '1.4.4'); wp_enqueue_script( 'reveal-scripts', plugin_dir_url( __FILE__ ) . 'js/reveal/jquery.reveal.js', array('jquery-1.4.4') ); 

А затем в jquery.reveal.js это следующая треска: https://jsfiddle.net/1z6p3fv8/

Я думал, что уникальное имя для wp_register_script будет использоваться только при вызове, в этом случае в конце wp_enqueue_script.