Конфликт шаблонов с WC Метод оплаты

Итак, снова я пришел сюда, чтобы попросить вас о помощи.

Я использую шаблон Apus RealState с WooCommerce. Все было нормально, пока я не установил модуль платежного шлюза …

Теперь WordPress записывает на консоль следующие страницы, которые я пытаюсь загрузить:

Uncaught TypeError: Невозможно прочитать свойство 'includes' of undefined

в HTMLDocument. (Erede.js: 6)
при i (jquery.js? ver = 1.12.4: 2)
в Object.fireWith [as resolveWith] (jquery.js? ver = 1.12.4: 2)
в Function.ready (jquery.js? ver = 1.12.4: 2)
в HTMLDocument.K (jquery.js? ver = 1.12.4: 2)

(анонимно) @ erede.js: 6
i @ jquery.js? ver = 1.12.4: 2
fireWith @ jquery.js? ver = 1.12.4: 2
ready @ jquery.js? ver = 1.12.4: 2
K @ jquery.js? Ver = 1.12.4: 2

Это контекст, упомянутый в файле erede.js:

(function( $ ) { 'use strict'; $( function() { var checkIfInputHasDefaultBehavior = $("#checkInputClass").css("background-image").includes("url"); if(!checkIfInputHasDefaultBehavior) { return; } 

но когда я меняю шаблон, эта ошибка перестает происходить … кто-нибудь знает, что может произойти?

Это может быть проблема совместимости с браузером (поддерживает ли он метод checkInputClass ?), Или может быть, что id checkInputClass не используется. Измените первую строку js на следующую, чтобы убедиться, что элемент существует до выполнения дальнейших проверок:

 var checkIfInputHasDefaultBehavior = $("#checkInputClass").length && $("#checkInputClass").css("background-image").includes("url"‌​);