Intereting Posts
Как переопределить the_excerpt, чтобы он отображал полный контент? widget_sidebar не работает Настройка постоянной ссылки Пользовательское имя типа сообщения и назначение пользовательской таксономии Как перенести веб-сайт на основе пользовательской базы данных в WordPress? Справка по мета-боксу или короткому коду Когда пользователь создает сообщение (ожидает ответа), отправьте ссылку подтверждения, которая позволяет им публиковать нужна помощь WordPress. Как отображать как home.php, так и index.php? Разрешить доступ к домашней странице и экрану входа в систему, но ничего больше (кроме случаев, когда вы вошли в систему) Как включить прокрутку переполнения таблицы? (особенно таблица списка заказов) after_setup_theme, глобальная переменная и Theme Customizer Загрузка плагина в формате .zip Переписывание URL-адреса настраиваемого сообщения на определенную страницу Создайте собственный URL-адрес для архива блога Связывание между страницами в wordpress

Что такое браузеры с поддержкой WordPress?

Я разрабатываю плагин, который предоставляет пользовательские клиентские компоненты html / css в области администрирования. Я хочу проверить совместимость кросс-браузеров этих компонентов с реальными браузерами, поддерживаемыми WordPress.

Есть ли официальный список браузеров, поддерживаемых WordPress, и по каким версиям?

Solutions Collecting From Web of "Что такое браузеры с поддержкой WordPress?"

Поддерживаемые браузеры будут меняться с каждой версией и темой, которые вы установили. Вы можете проверить заметки о выпуске или проблемы с trac, чтобы найти какие-либо несовместимости.

Лучшее, что я мог найти, это Browse Happy, но ничто в коммитах не сузилось или не отображало информацию о поддержке версий.

Таким образом, вы можете связать последнюю поддержку браузера с тем, как далеко назад вы хотите поддержать – https://www.impressivewebs.com/release-history-major-browsers/

Основываясь на этом ответе , вы могли бы связать все это обратно. Если ваши экраны меню или виджетов сломались …

WordPress 3.0.5 был выпущен одновременно с jQuery 1.5. К сожалению, у 1.5 есть некоторые обратно несовместимые изменения, которые, как представляется, разбивают несколько областей в админе. Сроки неловкие, и похоже, что это были мы. Это не так.

Мы ничего не можем с этим поделать даже для WordPress 3.1, который замерзает в jQuery 1.4.4.

Если ваша тема отменяет регистрацию jQuery и переписывает jQuery 1.5, тогда вы захотите убедиться, что это изменение применимо только к интерфейсу, то есть! is_admin (). (Или используйте wp_enqueue_scripts hook, который запускается только для темы.) Это может быть не очевидно: если вы запустили последнее jQuery, скажем, в CDN от Google, вы внезапно получите 1.5, и все будет нарушено ,

Кто-то должен собрать быстрый плагин, который восстанавливает и внедряет связанный jQuery в admin. Я сделаю это позже сегодня вечером, если никто другой не сделает.

Ссылка: # 16508 и многочисленные темы форума поддержки.

Но 6 месяцев назад jQuery.js был обновлен до 1.12.4, который показывает поддержку Safari 9 и IE 11 в журнале изменений .