Intereting Posts
показывать только термины из родительской категории post_title в действии save_post Цикл с двумя колонками с одной строкой Создание пользовательского виджета WordPress и остановка js от запуска дважды (один раз в активном виджетах один раз в селекторе виджета)? Расширение поискового запроса с дополнительным значением $ предложения Нужно получить массив идентификаторов изображений, прикрепленных к сообщению Как я могу разместить всплывающую страницу и перенаправить все ссылки на WordPress на эту страницу? Перенаправление на первый ребенок в пользовательском типе сообщений (без шаблона) Автоматически отправлять в Google+ новую запись Следующая страница ссылки не работает Как увеличить роль автора, чтобы иметь возможность добавлять новую категорию? Любой компонент Facebook не работает на веб-сайте WordPress после обновления. Зачем? подключаемая функция в теме, которая должна быть переопределена плагином Скрыть пункт меню в определенном состоянии Есть ли недостаток в использовании wp_defer_term_counting?

Новая установка WP из-за языковых проблем

Моя текущая установка WP на английском языке, я загрузил тему (так мило с YIT). Моя цель – создать магазин в шведском. Я пытаюсь перевести строки и т. Д., Я пробовал плагин WPML, и я также попытался создать новые файлы .mo и .po с помощью Poedit в соответствии с общими рекомендациями. Теперь я решил использовать шведскую установку WP и мой вопрос, прежде чем я это сделаю, если я просто могу перезаписать текущие английские файлы через FTP? В новом установочном файле есть wp-config-sample.php, но я полагаю, что это не работает, поскольку у меня есть исходный wp-config.php с правильными настройками «define», а также настройками базы данных и т. Д.? Спасибо!

Solutions Collecting From Web of "Новая установка WP из-за языковых проблем"

На самом деле не существует шведской версии WordPress, хотя они предоставляют удобный пакет с уже загруженными языковыми файлами. Единственными отличиями от основного (английского) распространения являются папка wp-content/languages , переменная $wp_local_package = 'sv_SE'; установленный в wp-includes/version.php , локализованный файл readme.html файл wp-config-sample.php .

Поэтому да, вы должны быть безопасно загружать непосредственно поверх текущей установки, пока вы загружаете тот же номер версии (от 3.9.2 до 3.9.2 или 3.9.1 до 3.9.1).

Файл wp-config-sample.php имеет комментарии PHP, локализованные на вашем языке, поэтому вы можете либо обновить переменные в этом файле из текущего wp-config.php просто переименовать его, либо вы можете просто установить define('WPLANG', 'sv_SE'); в вашем текущем файле конфигурации, если ваш штраф с комментариями на английском языке.