wp_insert_post не работает нормально

Я задал свой вопрос о stackoverflow, но ответа не получил, может быть, потому что это вопрос, связанный с WordPress. Поэтому я спрашиваю его здесь.

Я использую функцию wp_insert_post для вставки моих сообщений, но для меня это не работает.

Вот мой post_content

 $content = '<div class="snippet"> <strong>Wordpress Tutorial - Jetpack Plugin installieren &amp; konfigurieren</strong> <br/> <p>Wordpress Online Kurs unter http://wordpress-online-kurs.de Sie erhalten Tutorials zu den WordPress Themen, wie Plugins, Theme, SEO ...<a href=https://www.google.com/url?rct=j&sa=t&url=http://www.youtube.com/watch%3Fv%3DzjMtxin-hRA&ct=ga&cd=CAIyGmExYThkZTljMmU3MDQyZGE6Y29tOmVuOlVT&usg=AFQjCNGFOBEtFiT4f7zq6xl-xTbsW9uIVg target="_blank"></a> <br /> <a href=https://www.google.com/url?rct=j&sa=t&url=http://www.youtube.com/watch%3Fv%3DzjMtxin-hRA&ct=ga&cd=CAIyGmExYThkZTljMmU3MDQyZGE6Y29tOmVuOlVT&usg=AFQjCNGFOBEtFiT4f7zq6xl-xTbsW9uIVg rel="nofollow" target='_blank'>See Original Article </a> </p> </div> <div class="snippet"> <strong>Preview Fargo - Responsive Creative WordPress Theme TFx</strong> <br/> <p> Preview and Download : http://fxtheme.com/themes/fargo-responsive-creative-wordpress-theme-tfx FARGO is a beautifully designed and visually ...<a href=https://www.google.com/url?rct=j&sa=t&url=http://www.youtube.com/watch%3Fv%3DqjKCijxQR1M&ct=ga&cd=CAIyGmExYThkZTljMmU3MDQyZGE6Y29tOmVuOlVT&usg=AFQjCNGlUblc7rKI0OjRLqe1CChEfbpYmQ target="_blank"></a> <br /> <a href=https://www.google.com/url?rct=j&sa=t&url=http://www.youtube.com/watch%3Fv%3DqjKCijxQR1M&ct=ga&cd=CAIyGmExYThkZTljMmU3MDQyZGE6Y29tOmVuOlVT&usg=AFQjCNGlUblc7rKI0OjRLqe1CChEfbpYmQ rel="nofollow" target='_blank'>See Original Article </a> </p> </div>'; 

Когда я добавляю это как вручную, он вставляет, когда я использую cron, чтобы вставить его, просто вставьте сообщение до «SEO»,

Код:

 $my_post = array('post_title'=>'test post','post_content'=>$content); 

Любые предложения по его решению?

Solutions Collecting From Web of "wp_insert_post не работает нормально"